in

The Witcher: Monster Slayer. Incompatible device, version not compatible with the device

Lots of people have the same problem at this point. Mobile The Witcher is not compatible with their device. What can be done in this situation and will it change?


The main thing your phone should support is ARCore. If the device cannot cope with it, you can forget about playing Monster Slayer for now. Spokko, the publisher of the game, made available a list of compatible devices themselves.

As we know, the requirements may still change, but they probably won’t. There’s a small chance that if Monster Slayer isn’t working for you right now, it will suddenly start in a month.

The requirements are generally known:

  • OS: Android 9.9 (Pie)
  • CPU: Snapdragon 665 Octa-core
  • GPU: Adreno 618
  • RAM: 4 GB

For iOS:

  • OS: iOS 11.0 or later
  • Free memory: 1.5 GB
  • At least 6S or newer

List of phones compatible with The Witcher: Monster Slayer

Below you can find the full list, provided directly by the developers. It’s hard to say how up-to-date, but the last time it was updated was 14 days ago. If your phone is not here, we recommend checking the game anyway. There were cases where the Witcher worked after all.

So it should be treated as confirmation that everything works on the phone “X”, not that it will not go on the phone “Y”.

Back to Top